Mikrotik — автоматическое переключение на резервный канал

На складе подключили резервный канал (Yota) , надо настроить резервирование каналов:

eth3 — Основной канал
eth4 — Резервный канал

Прописываем IP для интерфейсов:

/ip address
add address=10.8.10.100/24 broadcast=10.8.10.255 comment=LAN disabled=no interface=eth2 network=10.8.10.0
add address=192.168.15.1/24 broadcast=192.168.15.255 comment=isp2 disabled=no interface=eth4 network=192.168.15.0
add address=192.168.20.253/24 broadcast=192.168.20.255 comment=isp1 disabled=no interface=eth3 network=192.168.20.0

Прописываем основные маршруты:

/ip route
add check-gateway=ping comment=gw1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.20.254 scope=30 target-scope=10
add check-gateway=ping comment=gw2 disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=30 target-scope=10

Прописываем маршруты для хостов которые будем пинговать , я пингую DNS Google и OpenDNS

/ip route
add comment=through_ISP1 disabled=no distance=1 dst-address=8.8.8.8/32 gateway=192.168.20.254 scope=30 target-scope=10
add comment=through_ISP2 disabled=no distance=1 dst-address=208.67.222.222/32 gateway=192.168.15.254 scope=30 target-scope=10

Сам скрипт я его назвал backupISP :

/system script
add name=backupISP policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":local PingCount 3;\r\
    \n\r\
    \n:local CheckIp1 8.8.8.8;\r\
    \n:local CheckIp2 208.67.222.222;\r\
    \n\r\
    \n:local eTo \"ndm.admins@domain.local\";\r\
    \n\r\
    \n:local rName [/system identity get name];\r\
    \n:local rDate [/system clock get date];\r\
    \n:local rTime [/system clock get time];\r\
    \n:local eSubj (\$rName . \" \" . \$rDate . \" \" . \$rTime);\r\
    \n\r\
    \n:local isp1 [/ping \$CheckIp1 count=\$PingCount];\r\
    \n:local isp2 [/ping \$CheckIp2 count=\$PingCount];\r\
    \n\r\
    \n:local BackGw [/ip route get [find comment=\"gw2\"] disable];\r\
    \n#if main ISP is DOWN and backup ISP is UP then:\r\
    \n:if ((\$isp1=0) && (\$isp2=\$PingCount) && (\$BackGw=true)) do={\r\
    \n:log warning \"Set routes to backup ISP\";\r\
    \n/ip route disable [find comment=\"gw1\"];\r\
    \n/ip route enable [find comment=\"gw2\"];\r\
    \n/tool e-mail send to=\$eTo subject=(\$eSubj . \" Main ISP is DOWN\") body=\"Set routes to backup ISP\";\r\
    \n}\r\
    \n\r\
    \n:local MainGw [/ip route get [find comment=\"gw1\"] disable];\r\
    \n#if main ISP is UP then:\r\
    \n:if ((\$isp1=\$PingCount) && (\$MainGw=true)) do={\r\
    \n:log warning \"Set routes to main ISP\";\r\
    \n/ip route enable [find comment=\"gw1\"];\r\
    \n/ip route disable [find comment=\"gw2\"];\r\
    \n/tool e-mail send to=\$eTo subject=(\$eSubj . \" Main ISP is UP\") body=\"Set routes to main ISP\";\r\
    \n}"

Далее нужно настроить отправку почты:

/tool e-mail set from=gw-central-warehouse@domain.local password="" server=10.8.254.7:25 username=""

Настраиваем планировщик который будет запускать скрипт каждые 30 секунд:

/system scheduler
add comment="" disabled=no interval=30s name=backipISP on-event=backupISP policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive start-date=jan/02/1970 start-time=02:13:10

Проверяем и радуемся =)
Отмечу вариант реализованный TangaRUS , не чем не хуже предложенным мною.

Mikrotik — автоматическое переключение на резервный канал: 7 комментариев

  1. Kantor61

    Специалист интернет маркетинг продвижение ипоисковая оптимизация сайтов website positioning 2014 torrent. И поисковая оптимизация. Маркетинг, продвижение и. Сайтов в сети интернет. Специалист интернет-маркетинг, продвижение ипоисковая оптимизация сайтов (search engine optimization) (2014) pcrec. Маркетинг, продвижение и. Сайтов в сети интернет,.поисковая оптимизация. Поисковая оптимизация. Машин и сайтов. Маркетинг,продвижение и поисковая. Интернет маркетинг, поисковая. И продвижение сайтов. Поисковая оптимизация. Создание продвижение и раскрутка сайтов www addtop information И поисковая оптимизация. Маркетинг в интернет,.сайтов и продвижение.
    Продвижение сайтов. Поисковая оптимизация.создание и поддержка интернет. Продвижение сайтов, поисковая оптимизация сайтов,.маркетинг в интернет и поисковая. Как работает интернет продвижение и. Поисковаяоптимизация. И продвижение сайтов. Курс интернет — маркетинг, продвижение и поисковая оптимизация сайтов (web optimization) пользуется огромной популярностью среди специалистов, а также тех,.
    Итак, если Вы решили начать продвижение сайта и настроены на ежемесячную работу с сайтом, если хотите заказать SEO сайта и готовы постоянно вносить изменения, анализировать поведение пользователей и внедрять новые разработки интернет-маркетинга, если Вы хотите развиваться и процветать, если Вам действительно интересно увидеть что-то новое в работе своей компании, тогда ЗВОНИТЕ!

    Что же такое эта поисковая оптимизация? Это целый ряд мер, который позволяет поднять ваш сайт выше в поисковой выдаче по интересующим вас запросам. При этом есть, как белые, так и черные методы для этого. Использование последних может привести к тому, что та или иная поисковая система просто забанит ваш сайт (это приведет к тому, что он будет недоступен в поиске).
    Поисковая оптимизация сайта в ТОП — процесс комплексный. Он требует аналитического подхода и технической подготовки. Именно поэтому мы работаем командно. Распределяя обязанности между аналитиками, программистами, оптимизаторами и копирайтерами. Это не под силу оптимизаторам-фрилансерам и мелким компаниям, но мы уверенно справляемся с самыми сложными задачами. А для достижения результата — формулируем четкую стратегию оптимизации сайта.
    Поисковая оптимизация сайта делается для того, чтобы продвигаемый ресурс мог получить лучшие позиции в выдаче поисковых машин по сравнению с конкурентами при прочих равных показателях. Чем лучше позиции сайта — тем больше посетителей попадает на Ваш сайт и тем больше от него будет отдача. Поисковая оптимизация страниц сайта делает более легким и дешевым продвижение сайта в интернет. Каждый опытный специалист по раскрутке сайтов согласится с тем, что раскрутка и продвижение сайта с антикризисным бюджетом реальны только тогда, когда правильно проведена поисковая оптимизация интернет-проекта!

    Планируете создавать сайты в интернете? — Для Вас целых четыре предложения сразу! Выберите нужное Вам! Если Вы только приступаете к созданию сайтов, оплатите курсы « Основы программирования и баз данных » + « HTML и CSS. Уровень 1. Создание сайтов по стандартам W3C и переход на HTML 5 и СSS three » и получите в подарок запись вебинара по курсу «HTML и CSS. Уровень 1. Создание сайтов по стандартам W3C и переход на HTML 5 и СSS three».
    Преподаватель с огромным опытом практической работы. Профессионально знает html & css, веб-дизайн, владеет работой с flash, растровой и векторной графикой, PHP и серверами. Богатый опыт практической работы и глубокие знания позволяют Кириллу Владимировичу излагать учебный материал доступно и понятно, живо и интересно. Именно эти особенности Кирилла Успенского отмечают слушатели в своих многочисленных благодарных отзывах.
    На конференции выступят: М.С. Полякова — консультант по бухгалтерскому учету и налогообложению, аттестованный преподаватель Института профессиональных бухгалтеров России; Е.Н. Вихляева — советник отдела косвенных налогов Департамента налоговой и таможенно-тарифной политики Минфина России; И.Р. Сухарев — начальник отдела методологии бухгалтерского учета и отчетности Департамента регулирования государственного финансового контроля, аудиторской деятельности, бухгалтерского учета и отчетности Минфина России.

    Курс «KL 302.98 Kaspersky Endpoint Safety for Home windows. Расширенный курс» — новый авторизованный курс Лаборатории Касперского в Центре «Специалист». Вместе с предшествующим курсом KL 002 «Kaspersky Endpoint Safety eight для рабочих станций и серверов Home windows» новый курс составляет комплексную программу обучения. Освоив эту программу, Вы сможете сдать обязательные экзамены Лаборатории Касперского. Именно Ваша квалификация позволит Вашей компании получить или сохранить статус партнера Лаборатории Касперского! Ваше руководство будет высоко ценить Вас!
    Оптимизация сайта под поисковые запросы требует достаточно кропотливой работы. Насколько это сложно, знают немногие. Казалось бы, вам все известно про ваше дело и многое — про работу поисковых систем, так что вы сами можете внести изменения в содержание вашего сайта, оптимизировав его под поисковые запросы. Только как практически насытить его содержание оптимально работающими для данной тематики ключевыми фразами, не утратив при этом удерживающей внимание пользователей внятности контента? В этом и заключается суть мероприятий по поисковой оптимизации сайта.
    Компания BDBD дает письменные гарантии результатов работы. Эти условия внесены в Договор и принимаются обеими сторонами. Если поисковая оптимизация сайта не приносит результатов, мы возвращаем деньги. То есть, оплачивая стоимость нашей работы, вы платите не за слова, а за конечный результат. Поисковая оптимизация сайтов Корпорацией РБС — это не набор разрозненных мероприятий, а выверенный упорядоченный процесс.

    Большинство WEBSITE POSITIONING-фирм предлагают услуги по развитию и повышению позиций internet-сайтов в Сети с привязкой к регионам «Москва» или «Петербург». Это оправдано с коммерческой точки зрения, так как количество потенциальных клиентов в этих городах очень велико. В то же время такой подход существенно ограничивает возможности компаний, ориентированных на региональные рынки.
    Это самоучитель для более знающих оптимизаторов. Это огромный труд профессионалов в области поисковой оптимизации сайтов, направленный на то, чтобы донести в массы всю ту важную информацию по оптимизации и раскрутке сайта, которой необходимо владеть для того, чтобы быть успешным в SEARCH ENGINE MARKETING оптимизации своего сайта. Получился, одновременно самоучитель, учебник и энциклопедия.
    Негпупые сайтовладельцы скажут вам, что сбор и использование данных веб-аналитики — это непременное условие для успешной оптимизации сайта. Это правда, потому что данные веб-аналитики предоставляют громадное количество информации о том, что посетители делают на сайте: что они читают, их перемещение по сайту, что покупают и чего совсем не замечают. Собирая, анализируя и используя этот источник информации, можно достичь максимальной оптимизации и эффективной работы сайта. А сервис Google Analytics поможет вам в этом.
    прайс-лист продвижение сайта: его ответ на http://promote-my.website/component/content/article/3-internet-reklama/42-internet-reklama-vis-tv.html

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *