ORF как перенаправить SPAM сообщения электронной почты в папку с нежелательной почтой (Exchange 2013-2016)

Открываем PS

1 Устанавливаем значение вероятности нежелательной почты равным 9

New-TransportRule "ORFJunkFolderRedirect" -SubjectContainsWords "[SPAM]" -SetSCL 9

2 Устанавливаем приоритет агенту ORF равным 1

Set-TransportAgent -Identity "Vamsoft ORF SMTP Receive Agent" -Priority 1

3 Перезагружаем транспорт почтового сервера

Restart-Service MSExchangeTransport

4 проверяем работу

Get-TransportAgent | fl

Настройки ORF:

2016-03-01 11-34-54 RUS-RDS-001

Перенос базы tempdb на другой диск

Сегодня Бухгалтерия начала перепроводить документы ну очень много =) и временная база стала весить больше 500ГБ =) пришлось перенести на другой диск.

use master
alter database tempdb
modify file(
name = tempdev,
filename = N'Z:\TEMP\tempdb.mdf')
go
 
alter database tempdb
modify file(
name = templog,
filename = N'Z:\TEMP\templog.ldf')
go

Скрипт PowerShell для импорта в лес Active Directory

На днях потребовалось загрузить больше 2к пользователей , руками делать тяжко, поэтому было принято решение  сделать все через PS

Подгатавливаем CSV файл

2015-10-19 17-47-24 UDPRF-IZV-DC

Далее запускаем скрипт

Import-Module ActiveDirectory
Import-CSV c:\users.csv | Foreach {
$param = @{
Name = $_.DisplayName
Department = $_.Department
Description = $_.Description
DisplayName = $_.DisplayName 
EmailAddress = $_.EmailAddress 
SamAccountName = $_.SamAccountName
OfficePhone = $_.telephoneNumber
UserPrincipalName = $_.UserPrincipalName
Path = "OU=Office,DC=CORP,DC=FIRMA,DC=RU"
AccountPassword = (ConvertTo-SecureString "Pa$$w0rd" -AsPlainText -Force)
}
 
New-ADUser @param
}

После выполнения скрипта новые пользователи создаються в OU=Office,DC=CORP,DC=FIRMA,DC=RU пароль Pa$$w0rd

Настройка IPSec IPIP tunnel Microtik v6.X <---> Cisco

На днях ко мне обратился хороший человек с просьбой настроить IPSec между офис (Mirotik) и дата-центром (Cisco).

Описание сети:

217.74.XX.XX — дата-центр
85.30.XX.XX — офис
10.80.80.0/24 — сеть дата-центра
192.168.101.0/24 — сеть офиса

Приступим к настройке:

  1. Создаем IPsec peer

2015-09-10 22-21-39 EXPERT2) Настраиваем правила IPsec

2015-09-10 22-22-23 EXPERT 2015-09-10 22-22-56 EXPERT

3) Настраиваем шифрования правил IPsec

2015-09-10 22-26-17 EXPERT

 

4) Создаем IPIP туннель

2015-09-10 22-20-56 EXPERT

5) Настраиваем маршрутизацию трафика в дата-центр через туннель IPIP

2015-09-10 22-26-43 EXPERT6) Разрешаем трафику проходить через Firewall

2015-09-10 22-27-31 EXPERT

На этом всё.

Шутка =)

Читать далее

Импорт содержимого PST файла в ящик Exchange 2013

Создаем группу Import-Export Admins с правами Mailbox Import Export далее добавляем пользователя justbox в группу Import-Export Admins

New-RoleGroup “Import-Export Admins” -Roles “Mailbox Import Export”
Add-RoleGroupMember “Import-Export Admins” -Member justbox

user001 — имя пользователя кому будем импортировать данные из PST файла
\\DFS\F$\PST\03.07.2015\user001.pst — UNC путь до файла

команда импорта: импортируем всю структуру (/) PST в почтовый ящик одинаковые папки\файлы будут обновлены

New-MailboxImportRequest user001 -FilePath "\\DFS\PST\03.07.2015\user001.pst" -TargetRootFolder /

Полный список стандартных почтовых папок ящика Exchange:

Inbox
SentItems
DeletedItems
Calendar
Contacts
Drafts
Journal
Tasks
Notes
JunkEmail
CommunicationHistory
Voicemail
Fax
Conflicts
SyncIssues
LocalFailures
ServerFailures

Active directory — Перенос пользователей между доменами LDIFDE

Старый домен DNS1.CORP.COM
Новый домен DC.CORP.RU

Выгружаем дерево OU в файл C:\Export\ExportOU.ldf

ldifde -u -f ExportOU.ldf -s DNS1 -d "dc=CORP,dc=COM" -p subtree -r "(objectCategory=organizationalUnit)" -l "cn,objectclass,ou"

Выгружаем всех пользователей в файл C:\Export\ExporUser.ldf

ldifde -u -f ExportUser.ldf -s DNS1 -t 3268 -d "dc=CORP,dc=COM" -p subtree -r "(&(objectCategory=person)(objectClass=User)(givenname=*))" -l "cn,givenName,objectclass,sAMAccountName"

Копируем папку C:\Export на сервер DC.CORP.RU в корень диска C:\

Через Notepade++ меняем строки DC=CORP,DC=COM на DC=CORP,DC=RU пример (Массовое изменение делается через поиск и заменить все):
до:

dn: CN=Justbox,OU=IT,OU=Firma,OU=Company,DC=corp,DC=com
changetype: add
objectClass:: dG9w
objectClass:: cGVyc29u
objectClass:: b3JnYW5pemF0aW9uYWxQZXJzb24=
objectClass:: dXNlcg==
cn:: 0JTQvNC40YLRgNC40Lkg0JrRg9C00YDRj9Cy0YbQtdCy
givenName:: 0JTQvNC40YLRgNC40Lk=
sAMAccountName:: ZC5rdWRyeWF2dHNldg==

после исправления:

dn: CN=Justbox,OU=IT,OU=Firma,OU=Company,DC=corp,DC=ru
changetype: add
objectClass:: dG9w
objectClass:: cGVyc29u
objectClass:: b3JnYW5pemF0aW9uYWxQZXJzb24=
objectClass:: dXNlcg==
cn:: 0JTQvNC40YLRgNC40Lkg0JrRg9C00YDRj9Cy0YbQtdCy
givenName:: 0JTQvNC40YLRgNC40Lk=
sAMAccountName:: ZC5rdWRyeWF2dHNldg==

Импортируем дерево OU

ldifde -k -i -f C:\Export\ExportOU.ldf DC1

Импортируем пользователей

ldifde -k -i -f C:\Export\ExporUser.ldf -s DC1

Так как пользователи перенеслись без паролей установим всем новый пароль:

dsquery user "OU=Company,DC=CORP,DC=RU" -limit 2000 | dsmod user -pwd "PaSSw0rd2015" -pwdneverexpires yes

Эффективный Failover на Mikrotik без скриптов

Есть два ISP-GW

ISP-1 XX.XX.34.53
ISP-2 192.168.9.1

Прописан маршрут до DNS Goole 8.8.8.8 через ISP-1

Нужно чтобы каждую минуту (допустимо в моей организации) проверялся канал если не доступен интернет на 1м ISP перевести интернет на второй

2015-04-05 09-44-07 iMac - Рабочий (899 642 573)

Настройка делается через утилиту Netwatch (находится в меню Tools)

Будем проверять DNS Goole 8.8.8.8

2015-04-05 09-43-13 iMac - Рабочий (899 642 573)

В раздел UP пишем:

/ip route set [find comment="ISP-1"] disabled=no
/ip route set [find comment="ISP-2"] disabled=yes

2015-04-05 09-46-49 iMac - Рабочий (899 642 573)

В раздел Down пишем:

/ip route set [find comment="ISP-1"] disabled=yes
/ip route set [find comment="ISP-2"] disabled=no

2015-04-05 09-49-36 iMac - Рабочий (899 642 573)

PPTP Server — Автоматически добавлять маршруты, когда клиент PPTP подключается

У меня есть два офиса нужно соединить их через VPN

192.168.10.0/24 OFFICE-1
192.168.11.0/24 OFFICE-2
192.168.48.0/24 VPN-LAN

Для каждого офиса создан логин пароль с привязкой к статическому IP-POOL (VPN-LAN)

root@router:/# cat /etc/ppp/chap-secrets 
# Secrets for authentication using CHAP
# client	server	secret			IP addresses
ppp1 pptpd 123451234567 "192.168.48.2" #OFFICE-1
ppp2 pptpd 123451234567 "192.168.48.3" #OFFICE-2

Все работает до перезагрузки сбивается маршрут , выход создать скрипт в директории /etc/ppp/

root@router:/# touch /etc/ppp/ip-up.local
root@router:/# chmod 755 /etc/ppp/ip-up.local
root@router:/# chmod +x /etc/ppp/ip-up.local
root@router:/# nano /etc/ppp/ip-up.local
root@router:/# cat /etc/ppp/ip-up.local 
#!/bin/bash
 
case "$5" in
        192.168.48.2)
                /sbin/route add -net 192.168.10.0/24 gw 192.168.48.2
                ;;
        192.168.48.3)
                /sbin/route add -net 192.168.11.0/24 gw 192.168.48.3
                ;;
        *)
esac

Теперь при поднятие интерфейсов будут прописывается маршруты в офис.

Если кому интересно могу описать установки и настройку PPTP Server Ubuntu 14.04

Настройка подключения Asterisk к продукту Офисный цифровой телефонии Beeline

PEER Details:

conext=contex-internal
type=friend
fromdomain=sip.beeline.ru
secret=PASSWORD
fromuser=7495XXXXXXX@sip.beeline.ru
defaultuser=7495XXXXXXX
host=sip.beeline.ru
canreinvite=no
insecure=invite
dtmfmode=rfc2833
outboundproxy=msk.sip.beeline.ru
username=7495XXXXXXX@sip.beeline.ru
srvlookup=yes
disallow=all
allow=alaw;ulaw

USER Details:

type=user
secret=PASSWORD
context=from-ptsn

Строка регистрации :

7495XXXXXXX@sip.beeline.ru:PASSWORD:7495XXXXXXX@sip.beeline.ru@msk.sip.beeline.ru:5060/7495XXXXXXX

Exchange — массовая выгрузка почтовых ящиков в PST-файл

Здравствуйте !

На днях потребовалось выгрузить все поточные ящики сотрудников + если есть архивный ящик его тоже с добавлением префикса архив

Как сделать :

foreach ($i in (Get-Mailbox)) { 
 New-MailboxExportRequest -Mailbox $i -FilePath "\\FSRV\PST-Exports\$($i.Alias).pst" 
 New-MailboxExportRequest -Mailbox $i -FilePath "\\FSRV\PST-Exports\$($i.Alias)-archive.pst" -IsArchive
}

Описание :

\\FSRV\PST-Exports\ сетевая шара куда будет выгружаться почтовые ящики

$($i.Alias) имя ящика

$($i.Alias)-archive.pst» -IsArchive имя ящика+префикс(archive)